Missing 5GHz Wi-Fi Networks

Holiday is a time for rest, relaxation and trips to exciting new places with family and friends. It is also a great time to rebuild your home network and spend long nights mucking about with firmware, conf files and cables. As I come to the end of my summer vacation, I have achieved at least some of the items in the above list.

In particular though, I have managed to rebuild my home network to make use of many of the bits and pieces I have had lying around waiting for something to do. As usual, 80% was straight-forward (or answers to problems were quickly found) but 20% were proper head-scratchers.

This post is about one of the 20%. Without worrying about why, for now, I switched one of the Wi-Fi networks in my apartment to the 5GHz band. This worked just fine for the two laptops I run in my house (both of which use Intel Wi-Fi adapters). The Linksys WMP600N PCI adapter that I added to my desktop could see nothing whatsoever on the 5GHz band.

Using inSSIDer, I was able to see a number of 2.4GHz networks (including one of my own at the other end of the apartment) but nothing on the 5GHz band. This misdirected my investigations for a time since it led me to assume that the card (or Windows) was not enabling the 5GHz radio.

After quite a bit of Googling and reading of unhelpful forum posts (the quantity of which suggest that laptop manufacturers need to be clearer about what the adapters in their laptops really support), I came across this post from ReginaldPerrin (post 8) on the Linksys forums. To summarize, he reminds readers that the regulatory situation for 5GHz channels is much more complicated than for the 2.4GHz bands.

Depending on the country you are in, your Wi-Fi equipment will be configured to support a particular range of channels in a particular way. Provided all your equipment was bought in the same country and you are not using custom firmware, you will probably not experience this issue.

The relevant part of my network consists of a Linksys E4200 running DD-WRT to allow it to act as a wireless bridge and get me coverage across my apartment. This was configured with a N-only, 5GHz network with automatic channel selection and a 40GHz width. Using inSSIDer on one of my laptops, I could see that the auto-selected base channel was 148.

A quick check against the Wikipedia table of Wi-Fi channels showed that none of the channels above 148 are legal in Europe. Setting the E4200 to use channel 48 as the base channel fixed the problem immediately. I have no idea whether this was down to Windows hiding ‘illegal’ channels or the Linksys WMP600N itself disallowing access.

A couple of observations

The forum post talks about a configuration page for the NIC that exists in neither the current driver, nor the driver than ships with Windows. This should allow you to configure the country and hence allowable channel. I guess the driver now works off the country locale of the host machine. I am using the ‘-EU’ suffixed card so it is possible that the allowed channels have been set in the card’s firmware. According to this, the card is probably a Linksys OEMd version of RALink RT3562. I might try the RALink driver to see what more I can do with that.

It is interesting that there are still very few 5GHz networks out there. The 2.4GHz band around my apartment is packed and it is difficult if not impossible to find clear-air. 5GHz is a ghost-town for now. If you want to improve your Wi-Fi reception and you live in a busy area, it’s probably worth investing in 5GHz capable gear. Use inSSIDer to find

Wi-Fi routers have to monitor for radar pulses and switch to a different channel if they detect them!